Triggering of questionnaires

Dear Sir/Madam,

We recently started our second wave of data collection using Ethica, but have been experiencing quite a few issues with the triggering of surveys (which we did not during the first wave in the Fall of 2019).

For instance, our background questionnaire, which should be triggered minutes after registering to the study, is not automatically delivered in about 10% of the cases (which means that we have to trigger it ourselves).

Another issue that we have been experiencing is that sometimes across the period of data collection, the surveys stop triggering. This issue does not seem to be limited to a specific type of phone (Huawei).

Could you perhaps take a look at what’s going wrong for our study? It concerns study #1043. Most recently, we got a message from user #15548 that they did not receive our evening questionnaire (#5839) yesterday and the day before, and also not the day questionnaire this morning (#5359).

I hope you can help me figure out what’s going wrong as, as you can imagine, the issues have had quite an effect no our data collection.


Hi @e.l.demoor

Thanks for reporting this issue and I’m sorry that you’ve had a frustrating experience so far. We are not seeing a substantial drop in the compliance of surveys across our system as you explained. So for us to investigate the cases that you explained, we need to have a bit more information. At least for example who experienced the problem, and around what time.

I looked specifically into the User #15548. For this user, I checked all surveys responded from Jun. 4th to today, which involved survey #5358, 5366 and 5839 (the evening survey), and 5359. But for all these surveys, our records showed the surveys were all prompted at the right time.

We will be looking further into this and run more tests to see if we can find any issue specific to this participant (a Huawei user). In the meantime, if you have any information that you think can help us identify any potential problem sooner, I’d be grateful if you can share it.

Thank you

Hi @m.hashemian,

Thank you for your reply. Today we experienced another problem with the triggering of questionnaires. This happened for a person who first registered to study 1043 as Ethica user #28099 and then later, after restarting and even reinstalling the app, as user #28100. We even tried manually triggering the first questionnaire twice for user #28100, but they didn’t receive it. Can you see what the problem is and how we can solve it?

Thanks in advance,

Hi @e.l.demoor

Can you please confirm the phone’s clock shows proper date?

Our server records show the person was working with the phone on Jun. 17th around 6:42 pm Amsterdam local time, but every report we received from the phone had a timestamp of Jun. 16th 6:42 pm!! It seems the phone’s clock is 1 complete day behind.


This solved it, thank you!