Registration problems

Study ID: 1410


there are so many issues with Ethica right now that I don’t know where to start. After registering for the study, some participants could only see this: “Sorry, something went wrong”. In the beginning, this was only for 6 participants the case, now over 30 participants have this problem. Even after sending the new invitation, the problem is not solved. My study will start tomorrow and almost half of the participants have problems with it now… I hope you can help me with that.

Kind regards,

Sare Danaci

Hi Sare,

The problem is that in your survey ID 7723, first question, you use the following image URL:

You need to download the image from this website and upload it to the Ethica’s Survey Editor. This allows Ethica to create a smaller version for the image, and show that in the survey. If you make this change, things should work as expected.


Hi Mohammad,

Thank you for your response. I wanted to delete the picture but right now I am not able to make any changes at all? When I click on the survey and on “Questions Flow”, I only get a blank space.

Also, the first survey should have started today at 8:00, but nothing happened…

Kind regards,
Sare Danaci

Also, the participants that were able to fill in surveys yesterday, now also receive this “Sorry, something went wrong”.

So it is a bit weird to have all these problems because of one picture, especially when it worked for some yesterday and now it just doesn’t…

Hi @saredanaci27

I believe my colleague from Support is following this issue with you. I guess we can continue the conversation there.