Problems with registering and then getting notifications

Dear Sir/Madam,

In a trial of the next wave of our data collection, one of my colleagues experienced some issues with registering in the study, and then with receiving the questionnaires. At first, she received a message that she could not register in the study. When she was at last registered but did not receive any questionnaires, she attempted to manually trigger a questionnaire but received the “Oops, something went wrong” pop-up. Now, ethica shows at least for this registration that she did receive questionnaires, but that 1 was blocked and the others were not answered (ID User = 30228).

Some more information:
Study code = 1314
Phone = iPhone X, iOS 13.6
Registrations attempts:
30228 (this is the attempt mentioned above, which Ethica indicates did receive questionnaires)

Looking forward to hearing what you think may be the problem and how to solve it!


Hi @e.l.demoor

The problem is with Survey # 7028. The survey is set to expire after 7 hours, but it also has a notification that is scheduled to be prompted exactly after 7 hours. The app could not schedule this notification, because it would fall exactly on the time that the survey would expire. So the app shows an error.

You can solve this by either extending the survey expiry time, or by prompting the 7th notification slightly earlier.

After you make this change and publish the survey, please go to the app and press “Reload Studies from Server”, and this should resolve the issue.

Thank you

Hi @m.hashemian,

Thank you for responding to my post! I have solved the issue that you mentioned and asked my coworker to reload the studies. However, this did not solve the problem for her and reloading gave her the message: “Sorry, something went wrong”.

I have asked her to try re-registering but this again results in the message “Could not register in the study” (ID = 30295). She could reopen her old account in which she was able to register (ID = 30228), but she still received no questionnaires even when manually triggering them.

Could the problem be related to the type of phone or software the phone uses?

Hi @e.l.demoor

The problem was still with the survey # 7028, and was not resolved. As you can see in the image below:

The survey was configured to expire after 420 minutes, but the 7th notification was set to “after 490 minutes”. I changed the 7th notification to 400 minutes, published the survey, and tested the study. Everything worked as expected.

I suggest you ask her to reload the studies and this time everything should work just fine.

Hope it helps,

This solved it, thank you so much for your help!