Joined studies are not showing in the "My Studies" column

The problem is, I tried joining study number 878 and 475. However, the feedback I keep getting is that I am already I am already participating in the study. But when I checked the “My Study” column in the Ethica App, the studies are not showing and i am not able to participate in the studies.

Kindly help resolve this.

Thank you.


Hey @spainer2010

We just updated our app with a new version. Can you please try this scenario in the new version of the app and see if you still get the same error?

Thank you

Hi @m.hashemian

I have exactly as you instructed but keep getting the same feedback.

Sorry maybe I wasn’t very clear. I meant can you update your app from Google’s Play Store and then launch the new version of the app and try again? The screenshot you’ve attached is related to the old app.

Thank you,

I deleted the App I had initially and installed a new one. The screenshots I sent you was taken after installing the new version as you directed.

Thank you

Well, the home page of the new application looks like this:

Which is very different than the screenshot you shared. So I’m sure you are still using the old version of the app.

Can you confirm your app is updated?

Thank you

Hi Mohammed, Sorry it’s taken so long to reply. I think that currently, we are good. However, there are a couple of things I need to bring to your attention. We designed a survey titled “Take a picture of a Barrier” and “Take a picture of a Facilitator”. However, the heading did not appear as such in the App on the smartphone. And also, these questions has been captured as optional activities, which shouldn’t be so.! Screenshot_2019-10-15%20Ethica%20Research%20Platform(1)|690x330

Please, how do we resolve this?

Glad to hear that it’s resolved. Regarding the survey caption, can you tell me which study ID and which survey ID this is related to?


Hi Mohammed,
Thank you for reaching out again. The Study ID is 475 and the Survey ID is 4570 and 4571. Moreover, our participants are not taking the pictures and we don’t know why. Can you help me diagnose that as well?

Thank you.

Hi @spainer2010

The caption of those surveys in the new versions of the app (those installed from a month ago up to now) are Take a picture of Physical Activity Barriers and Take a picture of Physical Activity Facilitators. But the old apps will use Take a picture!. Those who get the wrong caption for their button should update their app to the latest version.

As to why the compliance is lower than expected, I cannot talk much about that. You would need to follow up with the participants.

Hope it helps,

We are conducting a study with the study number #1408. Have have some time triggers (daily, weekly) in place. After our daily triggers expires, they disappear. However, the weekly ones gets moved to the heading “optional activities”. This is confusing the participants. How do we remove the optional activities and still have a surveys appearing to them on weekly basis?

Thank you

Hi @spainer2010

That’s because your weekly surveys have a User-Triggered triggering logic as well as their Time-Triggered triggering logics, so when their weekly sessions are expired, the app moves them to the Optional Activities to allow the user to complete it if they want.

You should remove the User Triggered ones, and then it should work as you expect.