Export column header mismatch

Exports from survey have column headers that don’t export correctly leading to column headers mismatched with responses when opened in Excel and Google Docs. Study ID: 2485, Acitivity ID: 15800.

I also second this issue. My column headers are messed up when exporting surveys. Study ID: 1480, Activity ID:10941

Hi @echo @n.a.huizinga,

This issue has been resolved a couple of days ago and everything work as expected. Could you please confirm if you generated the export yesterday or today? If yes please send the export ID, otherwise please recreate the export and everything should work as expected.


I believe that I exported it on Tuesday. It would have been export ID 5. I tried it again just now (export ID 6) and the headers are still messed up. It has some answers as a header instead of the question. I’m looking at survey responses for 15780 (I had requested multiple). It’s also messed up in survey 15800.

It still doesn’t work correctly for me either. I tried it again just now and nothing has changed. It’s messed up in survey 10941. And it looks like the issue occurs specifically with questions where the participant can choose multiple answers.

Hi all,

we’ve identified the issue and a fix will roll-out in couple of days.

Sorry for the delay and thanks for reporting this.


Hi Faham - this issue still seems to be occurring in the export I made just now (export 12, see Survey 15780 for an example). It seems to happen for answers to a multiple-selection question when a comma was included in an answer. Any update on when this will be fixed? I have work that is pending this fix so if there is anything you can do to get this fix in place it would be greatly appreciated.

Hi @echo,

The fix for it is going to roll-out today or tomorrow at the latest.


Hi Faham - the column headers are still messed up. If the fix has rolled out it doesn’t appear to be working.

. This was just exported now (Export 15 on Activity 15780).

Hi @echo,

The fix just got out less than an hour ago. The problem should be resolved. Would you please try again and let us know if still had any issues.



I also have issue in my study (ID: 2406, 2591 and 2593). I have downloaded the data in Ethica and exported the csv files to excel, delimited by comma’s. In general this looks fine (after deleting all the comma’s in the headers manually, so the headers are not splitted like @echo anymore). However, the answers are not matching the headers (at all). Moreover, the mismatching seems to be inconsistent, so I could not find an easy solution.

Can you maybe help me?

Hi @l.braas,

You shouldn’t change the headers. MultiAnswerQuestions or MAQs are designed to have one separate column per Answer. This is the official format of the exports now. Please try importing your CSV export to Google Spreadsheet and let us know if there is any issues.


Hello @faham,

Thank you for your answer. Unfortunately, the document is still not well structured when I open the csv file in google spreadsheets. The headers look fine! But in general, the number of characters in csv file does not fit the number of columns in the sheet. The first ±20 columns look fine, but further!
all the rows are shifted to the left. In addition, I noticed mismatches when participants answered the follow-up questions. Our study is divided by 4 topics, each starting with single answer question (yes/no). If they answered yes and were referred to follow-up questions, the mismatch occurs and the row shifts a few cells to the right. If participants answered no, they were directly referred to the next topic.

*picture 1 shows the general mismatch: VAS scale question answered by yes/no
*picture 2 shows the mismatch when participant answered a few follow-up questions. Number questions are answered by yes/no… and a few a shifted to the right

I would like to hear from you.

Kind regards,

Lisan Braas

@l.braas could you please let me know your study ID and export ID?