Problems with notifications

For a few participants in study 723, the app stopped sending notifications. However, when they opened the app, they found a survey waiting inside the app itself. This issue happened with several participants, among which are participants 17484 and 16587.

For another participant (16069), when the participant clicks on the notification to respond to the survey, the survey does not open.

For another participant (18104), while the participant was responding to a survey, the app showed that the questions were all answered, although there were 3 more questions to be answered. The app therefore did not allow the participant to finish all the questions.

I would appreciate your prompt response as this could lead to a large number of missing data points for many participants who are currently enrolled in the study.

Thank you in advance.

In our study, the same problem occurred. Surveys are triggered at the correct times, but participants are not notified about the new surveys… The notification of a survey is now only visible in the app itself. Also, since the Ethica symbol is always present in the upper-left corner of the phones it is not really clear whether a survey is waiting for them or not.


Hi @h.eltanamly

Both these participants are using a Huawei device. Each Android device, depending on their manufacturers, have a different setting to allow apps to prompt notifications. Participants are expected to perform those settings on their phone in order to receive notifications. For example, for Huawei, you can read the steps here. The steps can be different depending on what kind of Huawei devices they have. You can find a list of all devices and the steps necessary to allow an app to prompt a notification here.

The only issue we noticed with 16069 is that like the other two participants above, she is also using a HUAWEI ANE-LX1 which causes problems for sending notifications. Similarly they should allow Ethica to prompt notifications in their phone’s Settings, in order for her to receive notifications from the app.

Assuming this is not a user error, we should observe the same behaviour for other users as well. Because it’s not possible for one user to be able to fully complete a survey, and another one observing this behaviour. Can you please try out this survey and the questions which you said cause the problem on your device and tell me if they worked ok or not?

I suspect the participant you mention also used a Huawei device which required the configuration in order to allow apps to prompt a notification. If you can tell me the ID of the participant, I can be more specific.

Thank you.

These are the users:


I figured out what caused my problems. In the JSON code of the survey, the line that indicated the notifications per time trigger was:

“notifications”: [ ],

Since it was the default, I was convinced that not specifying a specific set of notifications meant selecting ‘all notifications’, but it means ‘none of them’. When changing this into

“notifications”: [0],

everything works fine! So, no need to inspect the accounts anymore @m.hashemian. Thanks anyway.


Thanks Teun for your suggestion. So you did that yourself? The strange thing is that the notifications used to appear normally until last weekend. Even on Haweai phones. So I need to go online and add the zero to the code? Can you guide me where that is?


Thanks a lot @t.siebers for the note. @h.eltanamly there is no need to check your surveys for this. I’ve asked my colleagues to check in case this is an issue, and if that’s the case, we will be resolving it within the next hour.

Thanks again

Hi @h.eltanamly

The issue @t.siebers mentioned is because he used direct JSON editing to create his surveys, and he could use either:

“notifications”: [ ],


“notifications”: [ 0 ],

You created your surveys using Survey Editor, and the survey Editor properly sets all these parameters. So the issue that some of the participants do not get notifications is not that some setting is missing or is incorrect in Ethica, but it’s that the phone of these participants are configured to not to prompt notifications in order to save battery. If they set their phone to allow notifications, as I explained in the links above, they should receive the notifications as expected.

@t.siebers I was a bit unsure why your participants don’t get notifications, because they are using Samsung and Apple devices, and the issue discussed in this topic is related to Huawei devices. Your explanation made it clear then. You need to set:

“notifications”: [ 0 ],

As otherwise the app assumes it should not issue any notifications. The Survey Editor does it by default though.


Hi @m.hashemian,

We’ve just launched our ESM study and there are some participants that do not get notifications. We checked their general notification settings and their push notifications in Ethica, but they were all turned on.

Since this problem only applies to a small portion of our participants, and since most of them are iPhone users (possibly the ones with newer versions), we wonder how to solve this issue…

Is there anything that we can do to make sure that our participants will receive the notifications for future triggers?

Kind regards,

Hi @t.siebers

Sending in-app notifications are very different in Android and iOS. In Android phones, depending on the type of the phone, the notifications might not be sent unless the person performs certain changes. For example, while Samsung phones or Google phones work as expected, Huawei and Xiaomi phones sometimes don’t send any notifications to preserve battery, and the participant have to explicitly disable this feature which is not very straightforward. The conversation above, and this website explain more.

This issue does not exist in iPhones. As all iPhones are made by Apple, they all behave more or less the same, and this consistency has allowed us to be more certain about notifications being prompted on those devices.

But unfortunately, due to technical reasons, we cannot know when a notifications was sent. It’s not like sending an SMS or email where we can have a receipt confirmation. We only create a time-table of when we want the notifications to be prompted, and send that time-table to iPhone (and Android), and the rest is taken care of by the phone. We do not get any update or confirmation of any sort. So if you go to the Adherence -> Survey Sessions and correct times are shown there, it means we have asked the phone to prompt the participant at these times. If a given participant does not receive the prompts, very likely either there is something incorrect about their phone settings, or they’ve missed the notification (note that unlike SMS or Email, in app notifications can be dismissed and they wont see it until they open the app or via the red notification indicator in the app’s logo).

Regardless, if you provide more specific details about this case, including who experienced this issue, and which notifications specifically where not sent, we will do whatever we can to find out the reason where possible.

The conversation on this post also can help to better understand my comments above.

Hope it helps.

1 Like

I had the same problem in our study: The app stopped sending notifications and when participants opened the app, they found a survey waiting inside the app itself. However, the notification settings in the app and the android settings were all enabled and right.

I also found the following steps in the help forum, which worked for a day before the same issue started arising again:

“I suggest asking her to open the app, go to Settings and press Sync Data. When all data is successfully synced, she can go to My Studies and press Reload Studies from Server. So the settings of the phone will be in sync with server and hopefully she will be back on track.”

My study ID is 1413 and the problems arose specifically for participant 35765.

Kind regards,


In this case, there was a mistake on our backend server code. We resolved the issue and updated the participants’ device. The notifications should work as expected in your study now.

Sorry for the trouble,

Dear Mohammad,

Thanks for the response. Is there a way to tell from seeing the data that it’s due to some kind of error and not just someone not responding? I am asking so that we can act accordingly and inform you when the situation arises again.

Kind regards,

You can look at the Participant Audit Logs. These logs show every interaction a given participant has with the app, as soon as the interaction happens. For example, as soon as a given participant opens the app, a new log appears there saying “The participant opened the app” (unless she is offline). You can check there.

This is a new feature we rolled out a few days ago. If there is any glitches or if you have any suggestions or comments, please let us know.


A post was split to a new topic: Survey Critertia remained false

3 posts were split to a new topic: Problem with participant

Dear Mohammed,

I also have problems with the notifications: the scheduled notifications have not been sent. My study ID is 1740 and participant 38060 has problems witht the notifications. All settings for the app were set right.

Kind regards,


In our study (867) there are a few participants who dont get all the notifications for a survey. For examle EthicaID 41942 (label 10093) missed one on 5 october but told us that she really did not get any notification. She has an Iphone and all the notification settings are correct. Could you maybe help us out here because we have this for a few more participants.

Thanks in advance

In our study (1640) we encounter a similar problem for participant 45935. After difficulties getting the app to work (iPhone), there are no notifications. All the settings were checked to allow for notifications however.
Could this issue be related to the app, our survey or the phone? We hope we can resolve it soon.
Thanks in advance!

In our study (209) we also encounter this problem for participant 45407. Participant is working on Xiaomi. We checked all the settings. Also these But participant is still not receiving notifications. Thanks in advance for looking at it!